Is my computer compatible with your plugins?

We recommend using at least Mac OS 10.12.6 (Sierra) or later. For Final Cut Pro we recommend version 10.3 or later. For Premiere we recommend CC2017 or later.


by Patrick
January, Jan 15th, 2018

Subscribe for news and updates

Be the first to receive the latest news from CrumplePop.

×
Cart

Your cart is empty.